Authentication failing due to widespread provider outage
Resolved·Full outage

While our cloud provider (AWS) continues to recover from an earlier outage, our own observability platforms confirm that all services have returned to a stable state. We will continue to actively monitor all systems to ensure ongoing performance and stability.

Mon, Oct 20, 2025, 08:26 PM
(1 month ago)
·
Affected components
Roadmapping
Authentication
Integrations
Feedback & Idea Management
Administration
Updates

Resolved

While our cloud provider (AWS) continues to recover from an earlier outage, our own observability platforms confirm that all services have returned to a stable state. We will continue to actively monitor all systems to ensure ongoing performance and stability.

Mon, Oct 20, 2025, 08:26 PM

Monitoring

AWS appears to have fixed the issue, and our services have recovered. We are monitoring the situation closely.

Mon, Oct 20, 2025, 09:42 AM(10 hours earlier)

Identified

We have investigated and we are continuing to experience widespread issues due to an ongoing AWS incident with the US-EAST-1 Region ( https://health.aws.amazon.com/health/status ) . We will continue to provide update as the situation evolves.

Mon, Oct 20, 2025, 09:13 AM(28 minutes earlier)

Investigating

Our team is aware of an ongoing issue causing authentication attempts to fail. This is related to a widespread outage reported by our provider. We are in contact with their support team and are monitoring the situation.

Mon, Oct 20, 2025, 08:30 AM(42 minutes earlier)
Powered by