Feedback Portals Unavailable

Incident Report for Roadmunk

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 15:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2025 - 13:46 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 14, 2025 - 13:32 UTC

Investigating

Published Feedback Portals and the Feedback Portal management functionality are currently unavailable. We are investigating.
Posted Mar 14, 2025 - 13:00 UTC
This incident affected: Feedback & Idea Management.