Degraded Performance on our North American Regional Deployment (APP)
Incident Report for Roadmunk
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 17:28 UTC
Identified
Customers on our regional deployment in North America (APP) are currently experiencing degraded performance when viewing historical activity, audit logs, and notifications. We have identified the cause and are working on a resolution. Core roadmapping actions are not impacted.
Posted Jul 19, 2024 - 13:13 UTC
This incident affected: Roadmapping.