Investigating Errors in Roadmunk Application

Incident Report for Roadmunk

Resolved

The incident has been resolved
Posted Sep 03, 2024 - 21:04 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 03, 2024 - 20:55 UTC

Investigating

We are currently investigating this issue
Posted Sep 03, 2024 - 15:00 UTC
This incident affected: Roadmapping, Authentication, Feedback & Idea Management, and Administration.