Some services experiencing degraded performance

Incident Report for Roadmunk

Resolved

Performance has been restored
Posted Nov 29, 2022 - 17:17 UTC

Update

We are continuing to investigate this issue.
Posted Nov 29, 2022 - 17:14 UTC

Investigating

We are currently investigating issues where users are experiencing slow response times and loading times for roadmapping and authentication.
Posted Nov 29, 2022 - 17:08 UTC
This incident affected: Roadmapping and Authentication.