Identified Issue on Roadmunk Application

Incident Report for Roadmunk

Resolved

Good news! We were able to make the necessary changes to restore expected functionality within the Roadmunk application. Everything is operating as normal. Thank you so much for your patience.

Happy roadmapping,
Roadmunk Support
Posted Mar 30, 2022 - 22:39 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 30, 2022 - 21:48 UTC

Identified

Hi there,

We've identified an issue and are currently looking further into a solution. Our sincere apologies about this.

We will update you once a fix is identified. Appreciate your patience!
Roadmunk Support
Posted Mar 30, 2022 - 21:48 UTC
This incident affected: Roadmapping and Feedback & Idea Management.