Degraded performance for EU Regional Deployment

Incident Report for Roadmunk

Resolved

The incident has been resolved for customers on our regional deployment in Europe (EU).
Posted 9 months ago. Jul 17, 2024 - 11:13 UTC

Identified

Customers on our regional deployment in Europe (EU) are currently experiencing degraded performance when viewing historical activity, audit logs, and notifications. We have identified the cause and are working on a resolution. Core roadmapping actions are not impacted.
Posted 9 months ago. Jul 17, 2024 - 04:26 UTC
This incident affected: Roadmapping.