Connectivity Issues

Incident Report for Roadmunk

Resolved

AWS issues have been resolved and services moving back to normal. If you are still experiencing any issues, please feel free to out to someone from our team. Thank you.
Posted Dec 08, 2021 - 01:28 UTC

Monitoring

Our host AWS is experiencing problems and we are now seeing these issues having an impact on our application. If you have any issues accessing Roadmunk, please reach out to our team (support@roadmunk.com).
Posted Dec 07, 2021 - 18:51 UTC
This incident affected: Roadmapping, Authentication, Integrations, Feedback & Idea Management, and Administration.